502 Bad Gateway after upgrading Debian to latest version

There is a dash vulnerability on Debian, please following the steps below to check your system:

================================

  1. Log into your server as root
  2. Execute the following command:

env x='() ; echo vulnerable’ bash -c “echo this is a test”

3. If the output is “this is a test”, that means that your bash needs to be updated. Please refer to your specific OS below and update your system and bash to latest version.

and

================================
1. Log into your server as root
2. Execute the following command:

export dummy='() ; echo “exploited”‘

  1. Enter the following command afterwards:
    bash

  2. If the output is “exploited”, that means that your bash needs to be updated.

================================

On my Debian, I ran apt-get update && apt-get -y upgrade to update my system to latest version, then found my blog inaccessible, it gave me 502 Bad Gateway error.

I finally figured it out in http://jvdc.me/fix-502-bad-gateway-error-on-nginx-server-after-upgrading-php/.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s